Forum

Notifications
Clear all

[Closed] Site title and tagline missing from the website  

   RSS

0

I've selected the option to display site title and tagline but it is not appearing, help us out!

6 Answers
0

Dear @harshitagarg97

 

Please be advised that site title will not work if you are using a custom logo. 

Hope this helps. 

Have a great day. 

 

Best regards,

Eric

@themebeez
Hi there, thanks for such a nice theme! — I'm having an issue, thou. As you said, when using a custom logo the site description is not displayed. Can you please advice on a workaround to be able to show the site description below the custom logo?

I've been trying tweaking the padding and the image size with no luck, unfortunately.

Look forward to hearing from you!

0

Hello @mediaeditor,

Like we said you won't be able to use custom logo + site title & tagline in our themes. Therefore, if you wish to use custom logo please do kindly write your tagline on logo image itself. 

If you wish to use custom logo + site title & tagline you need to overwrite the header.php file by creating a child theme. If you are a developer you can do this or if you are not a developer, please feel free to find a freelancer who can help you.

 

Hope this helps. 

Thanks,

Eric

0

Hi Eric, sorry I just saw your reply.

I'm not a developer but have some knowledge with CSS and PHP. I'll go ahead and try with a child theme. My worry now is, that reading this forum I found out that there is no h1 tag by having the logo. Do you think I can solve this issue and have the logo and h1 if I manage to implement a child theme?

Thank you!

0

Hello mediaeditor,

That will work too. Let's take an example of Fascinate pro here https://demo.themebeez.com/demos-2/fascinate-pro/.  

While you inspect custom logo you see find a div called "site-branding". Right inside site-branding there are <a> & <img> tags. What you can do here is something like this below.

Check condition in header.php is_home() && is_front_page(). If that is the condition then implement this,

<div class="site-branding">
<h1 class="site-logo">
<a href="link to homepage"><img src="link to logo"></a>
</h1>
</div>

 

else if it is not homepage & frontpage do like below

 

<div class="site-branding">
<a href="link to homepage"><img src="link to logo"></a>
</div>

I hope you got the point. 

Thanks,

Eric

0

Thanks, Eric

I managed to identify the code and implement the first option in the header.php, but it turns out to display the logo and no h1 tag is created.

I'm using Cream Magazine free, and perhaps it didn't work because there isn't a class called site-branding, so I took what I could see the logo was defined by, which in this theme is logo.

Any further advice is much appreciated!

 

 

Sorry I just realised this is the wrong forum for my query, but it seems applies to all your themes.

I managed to do it well now, but the outcome is half-way there. Your suggested code does create an h1 tag assigned to the image (the logo) but the h1 tag renders "empty".

The worry, for me, is really on the impact of not having a properly configured h1 tag on the home page could have on the SEO of the website.
Can you shine some light on this?

0

Hello Mediaeditor,

Sorry I have to close this topic because each time you write a reply everybody associated with this topic gets an email. You can create a separate topic. 

Thanks,

Eric

Browse our handcrafted free & pro themes.

Get things done easily with our custom crafted services.

Fall in love with our friendly support team.